Forum Support Account won't go to payment page

Discussion in 'Support' started by MARK.II, Apr 30, 2019.

  1. MARK.II

    MARK.II New Member

    For the last 3 weeks every time I try to place an order on my account page I go from my trolley to the payment page which then goes to a page saying secure payment but will go no further, I have called screwfix 3 times and still no joy.
    Any ideas
     
  2. Astramax

    Astramax Super Member

    It's not good enough customer care, open a Toolstation account.
     
  3. Dam0n

    Dam0n Screwfix Select

    Thats exactly what happened to me yesterday. I gave up in the end and just went to the shop and ordered.
     
  4. Wayners

    Wayners Screwfix Select

    Try another browser. Could be a setting or cookie or even virus software stopping you but if you can get your order through with a different browser then you may be able to find and sort the problem knowing its a software problem.
     
  5. MARK.II

    MARK.II New Member

    I have toolstation as well, screwfix were doing well but tech support is slow to say the least
     
  6. MARK.II

    MARK.II New Member

    Likewise , it's bloody annoying
     
  7. MARK.II

    MARK.II New Member

    I have tried it on the phone,tablet and laptop with no luck but not a different browser I shall give it a go
     
  8. screwfix.peter

    screwfix.peter Administrator Staff Member

    Hi

    Sorry to read of the problems

    Please call our customer service team on 03330 112 112 or email online@screwfix.com with all the deals so we can investigate

    Peter
     
  9. MARK.II

    MARK.II New Member

    Hello Peter
    Tried that 3 times so far with no luck as the public can't call the Web tech team directly we have to wait for them to email back, maybe that needs changing, hopefully I will hear from them tomorrow as they are meant to be calling.
     
  10. MARK.II

    MARK.II New Member

    ?
     
  11. MARK.II

    MARK.II New Member

    Just tried another browser and it works, thanks for the heads up
     
    Astramax and Wayners like this.
  12. BFG

    BFG New Member

    Same problem. Gets stuck at card verification. The arcot.com plugin won't load, just a blank white square. Multiple PCs, multiple browsers, even blank browser profile to eliminate plugins. Tried via different ISPs, multiple devices multiple people different sgeo locations.

    It's not us, it's you, screwfix.

    No. Make the web site work. The most wonderful and productive thing about the internet and web sites is so you don't have to use the damn phone all the time. Recorded messages, press this press that, hold music, call centres, not being able to speak to anyone else while waiting - all telephone hell. Please fix your site.
     

Share This Page