Boiler filling loop not working

Discussion in 'Plumbers' Talk' started by Andrea.reon, Apr 2, 2018.

  1. Andrea.reon

    Andrea.reon New Member

    Hi all,
    I have an Electromax boiler (Heatrae Sadia), and I'm having a pressure issue.
    The pressure is near to 0.5, I know that it should be about 1.5.
    The filling loop was already connected, so my understanding is that opening both the valves of the filling loop the pressure should start going up. But when I open the valves nothing change (no noise of water or anything).

    [​IMG]

    Photo:
    https://drive.google.com/file/d/1uGz_Oo8STlh0aWiBw3Jrtl8a28PVlT5P/view?usp=drivesdk

    How can I bring back the pressure to 1.5?
     
  2. chippie244

    chippie244 Super Member

    What a lash up :eek::eek:
     
  3. Andrea.reon

    Andrea.reon New Member

    :eek: I had never opened a boiler before, so you can imagine my face when I opened this
     
  4. terrymac

    terrymac Screwfix Select

    Which two valves have you opened ,the two black ones ? And simultaneously ? If so the handle may not be turning the shaft below. Take the screw out ,pull handle off and turn the shaft 1/4 turn with a spanner.
     
  5. Andrea.reon

    Andrea.reon New Member

    Thanks for replying.
    Yes, I have opened the two black valves (attached a picture https://drive.google.com/file/d/1NQCSJp4dYbyFSsF02p1uEsWaa7udNeSx/view?usp=drivesdk ).

    The handle below is turned on (https://drive.google.com/file/d/1eAhLxZu_7bpvEnrLqakPQmOb_6kw95GN/view?usp=drivesdk)

    And the screw next to the valve is vertically aligned (https://drive.google.com/file/d/1saetJiOqbfBpFksrxwv0mOhU42RjfvFJ/view?usp=drivesdk)

    I also tried to move the screw horizontally, and to move the white plastic lever, but nothing.

    Should the boiler be switched on or off during these operations?
     
  6. ramseyman

    ramseyman Screwfix Select

    Yes boiler should be off. As said above are you sure when you turn the two black levers that they are actually turning the metal spindles they,re attached to? If you look there will be a little screw holding each on. Take those out, pull the levers off th en turn the spindles with an adjustable spanner or equivalent
     
  7. Andrea.reon

    Andrea.reon New Member

    Yes, the black levers are working correctly (I tried to connect just one end of the loop and open the lever and water come through on both sides).
     
  8. terrymac

    terrymac Screwfix Select

    Please take pic of pressure gauge. Is your boiler giving hot water and central heating as normally ? If its working OK then the gauge may be giving the wrong reading.
     
  9. Andrea.reon

    Andrea.reon New Member

  10. terrymac

    terrymac Screwfix Select

    OK ,so the filling loop issue isn't really an issue then. The pressure of hot water not being as strong from shower as it is from other taps is nothing to do with the pressure on the gauge. That gauge is showing the pressure in the primary circuit ( radiators ,underfloor heating if you have it etc) . it has nowt to do with the pressure of hot water coming from the storage tank to taps / showers etc. If all hot taps are OK but shower is weak its a problem with the shower.
     
    retiredsparks likes this.
  11. Andrea.reon

    Andrea.reon New Member

    Thanks for the help
     
  12. terrymac

    terrymac Screwfix Select

    Your welcome Andrea.
     
  13. rogerk101

    rogerk101 Screwfix Select

    To check if a filling loop is working or not, just disconnect the flexible hose on the CH side of it and point it into a bucket. If water shoots out of it when you turn the water supply tap on, then you don't have a problem with the filler loop (unless the double check valve on the CH side is stuck, in which case it needs replacing).
     

Share This Page