Dudley Vantage Cistern - no flush!

Discussion in 'Plumbers' Talk' started by dlonglegs, Mar 31, 2013.

  1. dlonglegs

    dlonglegs New Member

    My Dudley Vantage Cistern has just stopped flushing.
    It is the sort that has a pneumatically operated flush & previous failures have been due to the air hose coming off. However this is not so this time as I have been in & replaced the hose "just in case"
    The cistern itself is full of water & depressing the float adds more water.
    I suspect the problem is with the very end of the air tube as when I press the flush button I can hear a bubble at the bottom of the cistern, but cannot see, & have no info on what should be attached to where or how that end opereates the flush.
    I have tried the Dudley website for a diagram but can't find one. I am reluctant to try taking the unit apart with no info.

    I hope one of you professionals can enlighten me

    Many thanks.
  2. snezza31

    snezza31 New Member


    Have you tried disconnecting the tube from the push button and just blowing down the pipe?

    If the other end has become disconnected, you will hear/see bubbles coming from the end.

    If the cistern does flush when you blow down the pipe then it is the button that is faulty.

    The most common problem with that type of system is the little set of bellows in the button. If there is a split in the button bellows, the cistern wont flush.

    Hope this helps.

  3. Hi Mr Legs
    I've had one (actually several) that have done that
    What I have experienced is that the internal mechanism breaks (its a weakness) and you get no flush, replace the complete button.
    This is one I got from a google search, costs £26
    Without exact knowledge of what has happened I cant say for sure but that is what happened to me!

    Hope this helps


  4. dlonglegs

    dlonglegs New Member

    Thanks guys.
    It turned out to be a structural failure in the syphon, not a bellows problem.
    Managed to get a new syphon locally & we are now flushing well!

    Thanks for your help
  5. pgm

    pgm New Member

    Hi Snezza
    got a similar problem to dlonglegs.
    Tried your tip and disconnected pipes from back of push button and blew down them and it flushed fine, so I guess it is the push button.
    But I tried to blow down just one pipe then just the other to see if the half flush worked ok, but nothing. Couldn't blow down just one pipe.
    Its not that nothing happened I just could not blow down them singly?
    Could it be I have a single flush system ( no half flush) but just the wrong push button?
    However when I blow down both together it flushes perfectly.
    Any ideas please, any thoughts greatly appreciated
    best regards

Share This Page