Electric Shower Stopped Working. Has power but no water

Discussion in 'Plumbers' Talk' started by jetspray, Jan 27, 2014.

  1. jetspray

    jetspray New Member

    My electric shower, Mira Go 8.5, has suddenly stopped working. It was fine the day before. There is power to the unit, but the orange light comes on when you pull the pull main cord on, and the light stays on whether the on/off button on the unit is pressed on or off. No water comes out. No sound, no noises, nothing. I took the shower head off and ran water through it from the tap tap make sure it wasn't blocked. tried rotating the shower head speed when it was back on, nothing there either. Not sure what else to try. Clearly the fact that the light stays on has something to do with this. Any ideas?
     
  2. JustNick

    JustNick New Member

    Hi the electric solenoid in the shower has probably failed. You will have power but it controls the incoming water and has probably stayed closed as they need to be energised. A simple resistance check on the solenoid and you would be able to tell.
     
    jetspray likes this.
  3. jetspray

    jetspray New Member

    Thanks a lot, that has helped me Google on the faulty solenoid and that seems to make sense. I did go out and buy the exact same make and model from argos yesterday thinking that if it's going to mean paying for a replacement part and the labour, then I might as well just have a new one and get the warranty with it. Would you agree?
     
  4. wally

    wally Screwfix Select

    Depends how old your old one is, nick is probably on the right track & sometimes not worth repairing cost wise especially if something else goes on it shortly afterwards so I would say your logic is correct with a new one.
     
    jetspray likes this.
  5. Mr. Handyandy

    Mr. Handyandy Screwfix Select

    Before you do anything check that you have a good water supply to the unit. No supply = no activation.
    If it helps, I have a dim orange light on my shower all the time, brighter when running.

    Mr. HandyAndy - Really
     
  6. Hi Jetspray.

    That model has a push-button on/off switch? In which case the water flow will be operated by an electric solenoid as said by Nick above.

    Is it worth fixing? All depends on how competent you are (and bearing in mind we are talking water and leccy here...). And also how old - how much use - the rest of the machine has had. And how cheap the spare part is. And how cheap a whole new replacement is (Hmm - £99 - not bad :))

    Mira have a cracking after-sales service, and can supply pretty much any part for a decent price. So, if your machine is not old (say less than - ooh - 3 years) and hasn't been used excessively and you are a capable fellow and you promise not to kill yourself, then by all means get the part and fit it (usually a fairly simple dismantling job - all using very simple clamps and stuff).

    If not, fit the new one you've bought :rolleyes:
     
  7. tomhulme

    tomhulme New Member

    I've got the same problem. Mira Go suddenly stopped working. Power light is on, which then goes out when the on/off button is switched on. Solenoid resistance is 3.49, which should be ok, but no water, no sound, nowt.
     
  8. Blanca Reyes

    Blanca Reyes New Member

    If there is power to electric shower, but the water is not coming out, this can be either an electrical contact problem or the PCB as gained a fault which you may need to replace. Recently, in my electric shower there was same problem then New Jersey HVAC guy replaced the PCB and serviced the electric shower. Now, it is working properly.
     
  9. Joe Wilding

    Joe Wilding New Member

    Hi Tom,

    I've never used one of these forums before so not sure if this will work (or if you'll ever get to read this). You're the only one after weeks of research that has the exact same problem as me. Did you ever manage to find out what was wrong? A lot of people are saying that they can't turn their showers off etc, but you are the only one who's power to the shower cuts off when the push on/off button is pushed. I first changed the solenoid coil as I was hoping for a quick fix, but that wasn't the problem. Just bought a replacement unit matching the old (triton aquatronic 2 plus), installed it, and still the same problem. It's driving me mad.

    Really hoping you found a solution, as it would appear I can't even buy my way out of this problem.

    Regards,

    Joe
     
    Andy Lea likes this.
  10. Hey Joe (couldn't resist...)

    You bought a new, different make, shower and the problem remains as before?! Jeepers.

    Conclusion - it wasn't the shower wot was at fault. So find that ol' Mira and apologise.

    What could it be? From what you describe, I suspect a poor leccy connection betwixt the CU ('fuse box') and the shower itself.

    And the most likely contender is the mains isolating switch. Y'know - that big switch you clunk to provide power to the shower. It'll either be 'pull cord' or 'big red rocker switch'.

    I suspect wot's happening is that you have a very poor connection in there, and it's capable of providing enough leccy to keep your neon light glowing (ie - next to no power required at all...) but when you then ask it to draw 30+ Amps, that poor connection suddenly goes 'frazzle' and high-resistance.

    Are you leccy competent to a basic level - ie are you comfortable with taking off things like sockets and checking the wiring behind it? If so, then check your isolating switch for signs of burnt terminals.

    Next Q - were you about to do this without first isolating this shower circuit at the CU? If the answer is 'ooops!', then get a sparky in 'cos you are a prize twit.
     
  11. Mr. Handyandy

    Mr. Handyandy Screwfix Select

    You are getting mixed up DA. Joe is not the OP. Joe swapped for a matched unit.

    But it must still be 'power to' or 'water to' problem. ie Not internal problem.

    Mr. HandyAndy - Really
     
  12. Mr Ha, I'd be the first to admit to being generally confused... :oops:

    But my post above is anything but... :p


    (And I agree with your diog. :) )
     
  13. Joe Wilding

    Joe Wilding New Member

    I am really quite amazed that two people have tried to help me within a few hours. Thank you. Right, Mr handy Andy was right in that I swapped it for the same replacement unit (triton Aquatronic 2+), so all the connections matched etc and I would have spares for the future.

    I dont know about competent but of course I isolated electric/water before doing any work. I have checked the connections in the pull cord and they are tight as. Can't be 100 sure if a terminal is burnt due to a combination of reasons (position, darkness etc) but certainly didn't notice anything obvious.

    This one is really confusing me, and quite frankly depressing me. Really appreciate everyone's help though
     
  14. Oops - yep, I did misread that part... :(
     

  15. "the power to the shower cuts off when the push on/off button is pushed."

    Can you explain the sequence of events exactly?

    And what is your mains water supply pressure/flow like? Has this changed at all in this time?

    What indicator lights are on the unit and what do they do during this?
     
  16. Mr. Handyandy

    Mr. Handyandy Screwfix Select

    I guess the next step is to check you have good water pressure to the shower unit.

    Mr. HandyAndy - Really
     
  17. Mr. Handyandy

    Mr. Handyandy Screwfix Select

  18. Joe Wilding

    Joe Wilding New Member

    Right, so. Orange indicator light on pull cord is on all the time (it's supposed to be). I pull the cord to turn the shower on and orange indicator light comes on, on the shower unit. All good to this point. Then, when I start the shower by pushing the button I get nothing, no water, no noises, and the orange indicator on the shower unit goes out. It's as soon as I press the button I seem to lose all power. For what it's worth, the indicator by the separate pull cord remains on as expected.

    It quite literally suddenly developed this issue overnight. Nothing has been disturbed and all the connections remain tight and undamaged. Water pressure prior to the issue was good and did not ever fluctuate. No obviously no water.

    The supply cable is fine for the shower (8.5kw), and I did not have issues before. As already mentioned a complete replacement has not solved the issue, which in my mind eliminates the unit being the issue.

    It's really baffling me now, and rather annoying as I really hate baths.

    Really appreciate everyones input.
     
  19. Mr. Handyandy

    Mr. Handyandy Screwfix Select

    Could you do a little test. Turn all on as you have been doing. You say nothing.
    While everything is on, pull the cord a few times to see if there is any reaction at the shower.

    I'm thinking a very high resistance at the switch(pullcord) is preventing full power getting through to the shower, the heater requires more power than there is available, so kills everything.

    Pulling the pullcord while the shower is turned on, may 'chuck' momentary power and make the shower react at least momentarily.

    In that case, new pullcord switch.

    Mr. HandyAndy - Really
     

Share This Page