Issues With Aqualisa Digital Quartz Shower

Discussion in 'Plumbers' Talk' started by brush-head, Dec 4, 2011.

  1. Simon Wilson

    Simon Wilson New Member

    I have had a creeping death on the temperature on my aqualisa shower, in that it has being getting hotter and hotter each day for the same setting resulting in us progressively turning the temperature down, our normal temp is now below the word "cold", it completely stopped today, all lights on with the shower shutting off water after about 5 seconds. Thanks for the tip on holding the boost button whilst powering on, it took two tries for it to work. But now boost light off and the shower stays on, still over at the cold side. Reading the thread that sounds like a sensor problem in the control knob. Thought I'd post in case someone else has had a similar problem.
     
  2. Mr. Handyandy

    Mr. Handyandy Screwfix Select

    Does getting hotter and hotter also show decrease in water flow? Less water input, hotter water output = input blockage.
    Possibly!
     
  3. Simon Wilson

    Simon Wilson New Member

    No the flow is the same, if I move it to the extreme cold I get cold at the right flow and extreme right hot all at the same flow, so to me it points to more of a temperature sensor at fault. Thanks for your thoughts.
     
  4. Ben Westlake

    Ben Westlake New Member

    We had similar problem with our shower - which was fitted in about 2007 by previous owners. For about a couple of weeks we had a boosted shower - then it stopped altogether - the remedy was to replace the control unit (Existing part 293302 - new part 297908). So far, with the new part, the shower has behaved correctly. It is very easy to change the controller - just a single screw holding it in place. The part was not cheap though (~£70) - but better than having to pay for a new installation!
     
  5. Peter Norman

    Peter Norman New Member

    Since posting this shower has developed a fault whereby either getting no hot water or just tepid water. Processor seems fine so suspect its the controller at issue (the lights have not been working properly for yonks. Phoned Aqualisa to see if they could help with diagnostics and they stated it is very difficult to know if it is the processor or controller at fault. Gave me 3 options:
    Fixed Price Repair £335
    Complete new shower fitted £654
    New Controller £133
    Have gone with the latter on the basis that if it doesn't work the cost of it would be deductible against the complete repair option.
    Can't really complain as whilst the processor is a little under 10 years old the rest of the shower is nearly 15 years old so has done us well and if it is just the controller hopefully will be good for a few years more
     
  6. Peter Norman

    Peter Norman New Member

    New controller arrived, very simple to fit (slide bottom and top retainer rings and then slide controller up and it comes away, unclip data cable then reverse procedure for new assembly) and now working as good as new. Hopefully will now get a good few more years from shower
     
    Dr Bodgit likes this.
  7. Dr Bodgit

    Dr Bodgit Super Member

  8. areallnamestaken

    areallnamestaken New Member

    I came close to ordering a new front end controller for the Aqualisa Axis gravity pump version because the shower wasn't working and the lights just kept flashing without anything happening. I turned off the mains switch to the shower for a couple of hours after which it worked but for only about half a minute. Next, I came across this thread and tried the suggestion requiring two people. Switch off at the mains switch and wait a couple of minutes. Next, one person holds down the boost button while the other turns on the mains switch. It took three goes but the shower is working fine again. What is really strange is that when there was a fault the indicator lights continued to blink for a short while after the mains was switched off.
     
  9. Suthan

    Suthan New Member

  10. Richard Till

    Richard Till New Member

    Hi simon, I am hoping you will pick this up on you old post, I have exactly the same problem, did you resolve it with a replacement control know sensor or did you need a new processor ??
     
  11. Richard Till

    Richard Till New Member

    in case it helps anyone, this issue was resolved with a new processor not the on/off temp controller
     

Share This Page