Losing my modem.

Discussion in 'Other Trades Talk' started by devil's advocate, Jun 5, 2006.

  1. devil's advocate

    devil's advocate New Member

    About once a week, when I boot up the pooter to try and connect to the internet, I notice the power light on the Sagem modem doesn't come on - I know there's going to be problems...

    I then get the message 'The specified modem is already in use by another application or service'. I've tried sorting it out by searching for the modem and drivers the usual way, but I just can't locate the Sagem anywhere doing this (tho' I'm not an expert by a very long chalk)

    The only way I can get things working again is by uninstalling the internet modem drivers (Tiscali) and re-installing again. Everything is then fine - I usually connect at least once a day - for another week or so.
    Any ideas what might be causing this? It's really getting on my ***.
     
  2. ultimatehandyman

    ultimatehandyman New Member

    I used to have a similar problem with my usb modem, I could fix it by unplugging the usb lead for a minute or so, then plug it back in!

    This used to happen regularly when I was on win 98 and Millenium, now I am on XP it has never happened since.
     
  3. Astramax

    Astramax Super Member

    Had trouble connecting to internet recently, problem turned out to be the DSL filter on the telephone socket. Might be worth a try.
     
  4. Mr. Handyandy

    Mr. Handyandy Screwfix Select

    If the modem is a usb one and the power light does not come on, it is indicative that there is a loose connection(wires obviously-usb lead).

    Either check connections or if you have a spare, use another lead.

    As the modem draws it's power from the computers usb port, the lead is the most likely suspect.

    Unless of course the modem is connected via an external usb hub. If it is switching that off for a minute or two can sort it.

    You can find the modem and it's drivers in Device Manager(Shortcut=WindowsLogo+Pause/break)



    Mr. HandyAndy - really
     
  5. MOONSHINE

    MOONSHINE New Member

    Another ap or service. Have you checked for spyware? You can download from microsoft web to check for this. Also make sure you have upto date firewall & antivirus software. Could be redirecting.
     
  6. devil's advocate

    devil's advocate New Member

    Appreciate the replies, gents.

    Uhm, the computer goes into 'finding new hardware' mode, but can't find the drivers by itself (nor can I, for that matter), so I always have to go the un-install/re-install route. But why should this happen every week or so?

    Astramax, I'm pretty sure it's a 'fault' at the compter end since the power light on the modem doesn't come on, and the pooter can't find the modem. Thanks for the suggestion.

    Thanks, Mr HA - yes, the USB port is on the compter itself, not external. Do the ports have power going to them all the time even if the computer doesn't think there's anything connected? I'm wondering if, since the computer seems to think there's nothing there (or something completely different...), it just switches off the power to it?
    I don't think it's a loose connection because it just doesn't have these characteristics - I can move the cable with no problems, and it only happens on occasional start-up; never whilst the computer is actually running. Keep the thoughts coming!!!

    Moonshine. I did wonder about this - 'modem already being used by another appplication or service' did bring a chill to my bones...

    I've run Ad-aware and also have Grisoft anti-virus installed (both the free versions - I'm Scottish), and nothing has turned up apart from the occasional 'tracking' doodas, which are fairly harmless, I believe.

    Any more ideas gratefully welcomed. Many thanks.
     
  7. spider06

    spider06 New Member

    Have you tried posting the problem on

    http://www.pemech.com

    Some one on there is bound to have a solution.
     
  8. britishblue

    britishblue New Member

    D.A., what operating system is running? Is it Windows 98, 2000 or XP? What sort of modem is it, broadband or dialup?

    BB
     
  9. devil's advocate

    devil's advocate New Member

    Hi spider, I'll check that out - many thanks.

    bb, it's a broadband modem - 'Sagem f@st 800 E2T', and the pooter is using XP. Cheers.
     
  10. devil's advocate

    devil's advocate New Member

    Or I would try that link, spider, if it went somewhere... ;)
     
  11. MOONSHINE

    MOONSHINE New Member

    The light will only come on when connected to the net, It could be a fault with your modem or filter. Have you updated the drivers? Deleted any DLL files? Let us know how you get on.
     
  12. Mr. Handyandy

    Mr. Handyandy Screwfix Select

    DA, Yes the usb port has power available all the time(3-5v).
    How many lights are on your modem. It is not true that you only see a light when you hve a connection. You probably now that.

    Normally you would have 3 lights. Power(this will always be on when your computer is on).

    DSL. This will be on when the power light is on AND your modem is correctly connected to a phone line able to recieve broadband.

    Data. This will be on(flashing) when the power light is on AND you have a connection AND are recieving or sending data.

    Still, your power light is not on sometimes. Still, that points to a loose plug/connector.

    One thing is confusing me. You say the computer goes through the finding new hardware mode(when your hardware is not a 'new' find-or shouldn't be).

    Also you say windows can't find the drivers, neither can you, so how do you uninstall/reinstall ? How do you find the drivers then ?

    I have to repeat though, as soon as you plug in anything to a usb port, you should have power to it, no drivers are needed for the power. It's automatic.

    Try this. You will surely have another peripheral connected to another usb port on the same hub(the one on your computer). When the modem fails to show power, check to see if the other item is getting power.

    I would suggest if the other item IS getting power, it's definitely a dodgy modem or a dodgy connector.

    If the other item ALSO has no power, then you have narrowed it down to your computer failing to provide power at the usb hub.

    Phew!



    Mr. HandyAndy - really
     
  13. devil's advocate

    devil's advocate New Member

    Hi MOONSHINE and Mr HA (I appreciate the sweat!)

    My modem has two lights - power and ADSL. The power light usually comes on about half way during the boot-up process; the adsl light then starts to blink as it tries to make contact with the server (this has always been a bit of a hit and miss affair in itself - usually connects ok, but often takes 20-30 seconds or more blinking away before it goes steady and connects - sometimes it fails to connect and I have to reboot...)

    The problem shows itself with the power light not coming on even after the pooter has fully started. When the desktop screen appears, it usually carries the message 'The specified modem is already in use by another application or service' - how it arrives at that conclusion, I don't know, since theat's the only thing that's connected to the port. Sometimes the screen has the 'Found new hardware wizard' box, and asks if I want to install the driver.
    The only way I can get things back to normal, however, is by an un-install and re-install - I have to use the Tiscali disc.

    The adjacent USB port is used by a card reader. I'm pretty certain that its power light is always on - I'll double check the next time the modem cocks-up.

    Thanks gents for your thoughts.
     
  14. devil's advocate

    devil's advocate New Member

    Oh, I've shoogled the USB-modem lead every which way, and the light doesn't flicker. It vcertainly isn't a conventional loose connection, but I guess it could be a dry joint or similar?

    The power to the modem isn't always present, tho'; at least the power light doesn't come on until half way through the boot-up process. I suspect the modem itself requires a signal before it powers up, even if voltage is always being supplied to it. I have an infra-red receiver connected to a port, and this always shows a power light even when the computer is switched off...
     
  15. mj

    mj Guest

    Have the modem & computer got connections for a network cable ? My telewest modem works far better with a network cable rather than usb, seems alot less temperamental.
     
  16. Mr. Handyandy

    Mr. Handyandy Screwfix Select

    Sorry if I confused you DA. Yes, I mean there is always power - when the computer is on (fully booted).

    You will notice other things as the computer boots and switches on in sequence, like CDRoms/Recorders?DVDetc.

    The computer goes through each device, port etc switching them on as it goes. So yes, when fully booted, your modem should always have power.

    Please try another cable.

    Only other possible thing that comes to mind is a 'Device conflict'.

    This is where the computer has selected the same I/O port for more than one device, and one affects the other in a strange way.

    You can check for this in Device Manager. Or if you can find 'System Information' in All Programs/Accessories/System Tools(or something like that)


    Mr. HandyAndy - really
     
  17. gint

    gint Member

    isnt tony back tonight he'll know what the prob is, but it sounds like the lead. have you tried another usb lead ?
     
  18. devil's advocate

    devil's advocate New Member

    mj, I dunno - is it like a telephone socket type connection on the computer? I think I'd rather leave things as they are, tho', 'cos these are the bits that were supplied, and I'm just not clued up enough to start messin' around. Thanks for the suggestion, tho'.

    Mr HA, thanks for clarifying! Yes, I'm aware of the boot-up sequence; the hard drive always gives a little burp just as the broadband moden power light comes on - other USB devices come on at different times - the card reader, for instance, almost right away.

    Unfortunately, I don't have another cable. The pea inside my head is really telling me it can't be that, tho', 'cos of the reasons given before - (1)it's only on start-up; it never developes that fault off during use, (2)it copes with a big shoogle no problem, and (3) why would it come up with the 'specified modem...'/ 'found new hardware' messages if it was just a power supply wire fault?

    I'm going to try a couple of things - swap the modem and card reader ports and re-install drivers for both, and the next time the modem fails to power up, I'll test for voltage at the port.

    (Even tho' the power light doesn't come on with this fault, I suspect power is still being supplied to the modem - it just doesn't switch on until a trigger signal is sent from the driver, and it's some sort of software/conflict type fault that's occuring rather than hardware - that's my gut feeling :()

    Very grateful for replies - cheers.
     
  19. spider06

    spider06 New Member

    Sorry about that I can't understand why the link didn't work since that is the address.

    Google 'pc mechanic' it should pop up as the first result.

    Try the forums on there.
     
  20. devil's advocate

    devil's advocate New Member

    Thanks, spider, willdo.
     

Share This Page