Megaflow Problem

Discussion in 'Plumbers' Talk' started by BryBry, Sep 12, 2017.

  1. BryBry

    BryBry New Member

    Back in December I got the elements changed in my Megaflow tank. A few months later the fuse started tripping every so often. One time when I flipped it the plug for the tank gave a good sizzle. I had a sparkie friend have a look and he replaced the plug for me. All was fine until last week when I stopped getting any hot water. The boost still worked but I called the plumber back in and he replaced the thermostat once again at the start of the week but I'm still not getting any hot water.

    What else could be wrong with the damn thing?
  2. leesparkykent

    leesparkykent Well-Known Member

    An electrician with a multi meter should be able to find out what's wrong in about 2 minutes.
  3. andy48

    andy48 Active Member

    As I understand it , they shouldn't be plugged in, but permanently wired to a fused connection unit.

    They're normally 3Kw each, which is right at the limit of a 13A connection, so the slightest corrosion / tarnish on the plug or in the socket, which increases the resistance of the connection, can cause heating, and eventually arcing.
  4. nigel willson

    nigel willson Well-Known Member

    Sounds like a burnt out switch. I assume you said socket by mistake!

Share This Page