New bib taps not working

Discussion in 'Plumbers' Talk' started by Kate Roberts, Nov 8, 2019.

  1. Kate Roberts

    Kate Roberts New Member

    just replaced two bib taps outside with new brass bib taps onto 25mm pipe.
    Neither are working since turning water back on, any ideas?
    If it was just one id think it’s maybe a faulty tap...but both of them?
    Any ideas before I replace both taps tomorrow gratefully received!
     
  2. terrymac

    terrymac Well-Known Member

    Did you isolate the supply by turning off a gate valve , that has a big red ,round wheel head ?
     
  3. Kate Roberts

    Kate Roberts New Member

    I just turned the stop tap off before replacing them.
    Turned it back on but now nothing coming out of either tap...
     
  4. terrymac

    terrymac Well-Known Member

    Does the stopcock isolate other tap outlets ,which work OK. Or does it only isolate the two bib taps ?
     
    Kate Roberts likes this.
  5. Kate Roberts

    Kate Roberts New Member

    It’s the main (and only) stop tap
     
  6. nigel willson

    nigel willson Well-Known Member

    Have you used PTFE tape, have you taped over the inlet side of the valve
     
  7. ecoplumbing

    ecoplumbing Active Member

    Are the taps fixed onto a backplate? Take the taps off, turn the water back on. If water comes out you know the problem is with the taps
     
    Kate Roberts likes this.
  8. Kate Roberts

    Kate Roberts New Member

    Yes used ptfe tape but only on the threads, not covering the inlets
     

Share This Page