problems placing order

Discussion in 'Screwfix' started by james_15, Sep 14, 2014.

  1. james_15

    james_15 New Member

    My father has just spent all afternoon trying, unsuccessfully, to place an order with Screwfix. I have tried placing the same order on my own account, with similar results. We have tried 2 different computers with 2 different browsers. Everything is fine until you come to enter payment details, then the boxes for you to enter your billing address do not appear, so you cannot proceed with the order. Screenshot attached. Is anyone else having the same problem, and can anyone suggest a solution?
     

    Attached Files:

  2. Mr. Handyandy

    Mr. Handyandy Screwfix Select

    You seem to have gotten to the payment options without filling in your details and delivery options!

    Mr. HandyAndy - Really
     
  3. james_15

    james_15 New Member

    Thanks for the reply. Details and delivery options have all been filled in, but for some reason don't appear when we get to payment. We've even tried deleting and re-entering saved address details, to no avail. My dad had this problem once before and ended up having to order by phone. What's odd is that my account is also having the same problem.
     
  4. Mr. Handyandy

    Mr. Handyandy Screwfix Select

    So what happens when you click Review Order Before Submitting ?

    Mr. HandyAndy - Really
     
  5. james_15

    james_15 New Member

    It won't let you proceed, you just get an error message saying "Please enter billing address", which you can't. Just tried it again and noticed when you get to payment details, the boxes for you to enter a billing address do appear very briefly, for about a second maybe, and then disappear.
     
  6. Phil the Paver

    Phil the Paver Screwfix Select

    On your computer, try clearing the cookies.
     
  7. james_15

    james_15 New Member

    OK just tried that, closed and re-opened browser afterwards and the same thing still happens. It's just utterly bizarre, that this is affecting both my account, and my dad's account, on 2 different computers with different browsers, and yet somehow doesn't seem to affect anyone else.
     
  8. james_15

    james_15 New Member

    It's happening on my smartphone too, if I use the main site, although the mobile site works fine.
     
  9. SplittingDistant

    SplittingDistant New Member

    James_15,

    You're not alone - exactly the same problem was happening to me. I tried several browsers, turned off add-ons, anti-virus, and everything I could think of, still with no joy.

    The only way around it for me was to set up another account from scratch - and I guess that may be a problem if you only have one email address you can use.


    Good Luck!


    SplittingDistant.
     
  10. screwfix.peter

    screwfix.peter Administrator Staff Member

    Hi

    Sorry to hear you are having problems placing orders.

    Please email websitefeedback@screwfix.com with full details of the problems so we can investigate fully and help to resolve this problem

    Peter
     
  11. Mr. Handyandy

    Mr. Handyandy Screwfix Select

    Yer, in a couple of months time there may be another response, judging by the speed of this one ^^^
     
  12. james_15

    james_15 New Member

    Emailed the above address, and got a reply! Hopefully the problem has now been fixed but we have been advised to wait 24 hours.
     

Share This Page