Roller shutter unit - whom to call?

Discussion in 'Kitchen Fitters' Talk' started by enat, Apr 5, 2021.

  1. enat

    enat New Member

    I have a tall roller shutter unit on the kitchen which got stuck. I cannot open it more than 30 cm and then it rolls down (photo attached) so I cannot access the shelving behind it. The kitchen is 11 years old so out of warranty but I got the manufacturer's drawings for the unit (pdf attached) and the roller is accessed from the top hence the plywood panel would have to be cut out of the ply surround for the roller mechanism to be accessed + fixed and then the panel has to be put back and sealed.
    Do I need a kitchen fitter or a carpenter for this type of job? I thought a kitchen fitter because it deals with a kitchen unit but I am doubtful anyone will come out to fix just one unit.
     

    Attached Files:

  2. Teki

    Teki Screwfix Select

    Think you'd be best with a good kitchen fitter. Have you tried contacting Alno AG to see if they have any UK representatives?
     
  3. enat

    enat New Member

    Good idea - I have not thought of doing that. The problem I can envisage is that they only have a showroom in London where I lived at the time and not here in Oxfordshire so I am not sure they will be willing to make the trip but I can try and ask!
     
  4. teabreak

    teabreak Screwfix Select

    Just a suggestion I bet something on a shelf has toppled and is blocking the roller. Have you tried something thin and flexible (fishing rod, plastic strip, sink drain tool whatever) up between the roller and shelf and have a good thrash around!
     
    Teki and just pumps like this.
  5. enat

    enat New Member

    That was the first thing I tried but there is nothing between the shelf and the roller. I also tried pulling it up by force in case the jam cleared but with no success.
     
  6. Teki

    Teki Screwfix Select

    With the shutter down, try pushing downwards on the front near the top on the shutter with some force. Then try opening it.
     
  7. enat

    enat New Member

    Just tried, it didn't work - it would have been nice if it did though. It would have spared me a lot of trouble.
     

Share This Page