Titan TTB355CHN electric chainsaw stopped working

Discussion in 'Landscaping and Outdoors' started by Luke R Taylor, Sep 9, 2018.

  1. Luke R Taylor

    Luke R Taylor New Member

    Hello

    I have borrowed a Titan TTB355CHN electric chainsaw. It was working fine, but just stopped.

    I have checked that the kickback brake is not on, plugged into a different socket, and changed the fuse. All to no avail.

    Anyone any suggestions?

    I'm assuming that, if it's out of warranty, I will need to throw it away and get a replacement?

    Luke
     
  2. KIAB

    KIAB Well-Known Member

    Does it have a thermal cut out.

    Chain too tight, remove the chain & see if sprocket turns freely by hand,& try it plug in & see if it works.

    Got oil in tank.
     
  3. sospan

    sospan Well-Known Member

    Have you flipped the safety guard back into position ?
     
  4. ramseyman

    ramseyman Active Member

    Could be a break in the cable between plug and saw. I'd check for continuity.
     
  5. Luke R Taylor

    Luke R Taylor New Member

    Thank you all for your replies. I took the chain off and tried it again. It worked. Replaced the chain and it's still working.

    I think that, as I'm new to this chainsaw, I may have inadvertently tripped the kick back brake and got confused about which way was triggered and which way was not.

    So, all looks ok.

    Thanks again,

    Luke
     
    wiggy likes this.
  6. WillyEckerslike

    WillyEckerslike Well-Known Member

    No offence Luke but you really shouldn't be operating a chainsaw if you don't know how it works. One of the most dangerous power tools available.
    Professionals have to be certificated to use them yet anyone can buy them in Aldi. Madness!
     
  7. wiggy

    wiggy Well-Known Member

    Been there Luke, also cut through the cable once and stood there like a muppet wondering what was wrong. Petrols the way to go. Or cordless if you don't use it much.
     

Share This Page